Jump to content

Harbottle

TR Register Members
  • Content Count

    80
  • Joined

  • Last visited

Everything posted by Harbottle

  1. Just a thought, check inside the hole it left behind in case something is still there.
  2. Hi Guys Sounds like something floating about in the fuel tank and coming to rest now and then over exit for the fuel. One of our club members had a similar problem which turned out to be the small cardboard disc from a cap of fuel additive which fell in!!. Took a while and a lot of fishing about with a stick and pin thing to remove it. Paul
  3. Jealous, Who's jealous Paul
  4. Hi Stuart Me too for this. There is a lot on the forum about keeping the engine cooler and fuel evaporation problems, which cooling fan to use etc. This has to increase heat retention doesn't it? Paul
  5. Harbottle

    Body panels

    Hi Mike Did you spray it yourself or have it done elsewhere. How did you go with the paint match. Paul (redrose)
  6. iani X2 You will save so much time/hassle in the future should you have a problem with pipes or tank or just want to clean up the boot area. My pump is also in the wheel arch and this gives you a little more space to use in the boot also. Paul
  7. Are you sure there is no one locked in the boot!
  8. MrG is too close to MG for my liking. Welcome to the forum Bob Paul
  9. Harbottle

    PXE 814F

    I knew I would spell the Piskey I mean Pesky thing wrong
  10. Harbottle

    PXE 814F

    Should be Cornish with PXE (Pixie) as a reg.
  11. as above but with some oil and a spare ignition barrel and key. mine snapped off inside once
  12. Thanks for posting Michael. A very interesting read on the TR5. Shall spend some Christmas time exploring more. Paul
  13. Harbottle

    Petrol Smell!

    I had a scimilar problem a couple of years ago with my alloy tank. Strong smell when tank full which gradually reduced as more fuel used. After usual connections checked etc, removed tank to discover that one of the baffles inside the tank had come adrift at the top weld causing a small whole to appear. Hence the cause of strong smell reducing as fuel used. Remove tank and check all around for cracks etc as this was only visable when removed. Paul
  14. Thanks Stuart I didn't know I got car sick till I saw that. Paul
  15. Two topics down from this, Roger has posted a TR5 at the Earl's Court Motor Show 1967 and it has painted trim. Regards
  16. Hi All Mine is a UK 1968 TR5 and has painted wing mouldings, I don't know why some have not.Understood they should all be painted body colour Regards
  17. Hi Stuart I got a 4 post lift several years ago and very happy with it. Idea was to store additional car underneath which is fine but it only came with three oil drip trays. Suggest which ever you get check how many it comes with to ensure enough to cover whole ramp area. Paul PS and Steve is right they are very heavy, get help assembling.
  18. Harbottle

    Mohair roof

    Hence the expression " Hang on a Mo" Ho Ho
  19. Hi Guys Sorry for the delay in replying to you and thanks for the help.Steve I have an original tr5 pi uk model 1968. I have installed a new wiring supply with relay and car starts a sounds fantastic. Chris thanks for the tip about fuel filter, I have removed it and cleaned it out with new gause fitted. I will now check the ignition switch just to make sure it is ok. Many thanks for the help as always. Paul
  20. Hi Steve Thanks for that. I thought it might be something like that. I have some new wiring with a relay that I was going to get around to fitting, now is the time. I just wanted to make sure it was not the pump itself that might be at fault. Many thanks Paul
  21. Hi John No there is no relay. thought that myself but the clicking is definately from the pump itself. Paul
  22. Hi guys, Have been living with and it is now getting worse a clicking noise coming from my fuel pump. When I turn the key on stage one you can here the fuel pump gurgle as it starts to suck but when the key is turned to second stage to fire it up there is nearly always a clicking noise from the pump. The car does not start and I have to turn the key back and then forward again before it will fire into motion. The number of times I have to do this is variable sometime one retry sometimes four or five. The pump is under the wheel arch and I have checked the electric connections which seem fine. There is a small glass pre filter from the tank to the pump and the pump is a Bosch one. Car seems to run fine when going. Any ideas as to what might be causing this would be gratefully received. Paul
  23. Hi Nick mines got one fitted to the frame,done by the previouse owner via Revingtons I believe. Paul
  24. Hi Brett I did this with my 5 and put a K & N filter in the original chamber and it seems to work fine.The entrance hole for the chamber points away from the radiator and down towards the o/s front. I understand this was the original design for the TR5 while others point towards the radiator.
×
×
  • Create New...

Important Information

Please familiarise yourself with our Terms and Conditions. By using this site, you agree to the following: Terms of Use.