Jump to content

Search the Community

Showing results for tags 'engines'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • TR Register Information
    • JOIN THE TR REGISTER
    • Find your local TR Register group
    • TR Register News
    • Events
    • TR Register Insurance
    • = CORONAVIRUS UPDATES =
  • Parts and Cars
    • Classifieds
    • For Sale, Swap or Wanted, maximum value £250
  • TR Register's TR Chat
    • TRs Out and About
    • General TR Technical
    • TR2/3/3A/3B Forum
    • TR4/4A Forum
    • TR5/250 Forum
    • TR6 Forum
    • TR7/8 Forum
    • Italia, Swallow Doretti, Peerless & Warwick
    • TR Motorsport
    • TRs Re-United
    • Social Scene
  • Help Topics
    • Forum Help / Rules
  • Useful Links
    • Contact the office
    • Facebook
    • Twitter
    • Members' websites

Calendars

  • Forthcoming Events
  • Community Calendar

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Location


Cars Owned:

Found 1 result

  1. Hi All, Before I proceed with a costly engine rebuild i would appreciate any advice on this. I have a newly refurbed head and excellent compression test readings, 200psi across all cylinders. However in a leak down test I'm loosing pressure, approx 20% on average. The engine does consume rather a lot of oil so there is an issue but not sure where. Also the hot oil pressure is reasonable, 25psi at idle and 60ish at 2000rpm. The engine doesn't overheat and the oil looks fine. Is it due to bore wear? Any ideas as I can't understand the contradicting pressure tests. Cheers
×
×
  • Create New...

Important Information

Please familiarise yourself with our Terms and Conditions. By using this site, you agree to the following: Terms of Use.