Jump to content

Recommended Posts

My TR250 has a saloon gearbox fitted. I have just wired up the solenoid and it doesn't seem to work. It doesn't make a noise when switched on. I have checked the current and it is taking about 2 amps so electrical side is OK.

Can these be serviced/ repaired? New solenoids seem to be well in excess of £100.

Thanks Eddie 

Link to post
Share on other sites

Hi Eddie,

The solenoid on the 'J' overdrive I recently rebuilt was not working. However I removed the small circlip from the end and withdrew the piston. I found tapping the end of the solenoid did not fully remove it, but a self tapping screw that just engaged in the hole in the end of the piston allowed it to be pulled out. Cleaned it up, fitted a new O ring and reassembled. Now works. Worth a try.

Rich

Link to post
Share on other sites
22 hours ago, rvwp said:

Hi Eddie,

The solenoid on the 'J' overdrive I recently rebuilt was not working. However I removed the small circlip from the end and withdrew the piston. I found tapping the end of the solenoid did not fully remove it, but a self tapping screw that just engaged in the hole in the end of the piston allowed it to be pulled out. Cleaned it up, fitted a new O ring and reassembled. Now works. Worth a try.

Rich

Hi Rich, where did you get the O rings, and is there just onne?

Cheers, Colin.

Link to post
Share on other sites

Hi Colin, got it from ORS Ltd when I ordered a gasket and seal kit. I think there is only one internal, (can't remember for sure) but two external,   Give them a call and they will confirm. Problem is at the moment most of the employees have been pinged and are self isolating!!

Rich

Link to post
Share on other sites
  • 4 weeks later...

Hi Eddie,

Despite what I said re cleaning the solenoid and replacing O rings, although it appeared to work on the bench and it looked good, it would not work when fitted to the OD although I could  hear it function!

I substituted the solenoid from my TR6 which has a 'J' OD and it worked, so pointing to a solenoid problem.

Further discussions with ORS Ltd revealed that most of the problems with 'J' OD's not working are solenoid related and they have experienced similar problems. So I have bitten the bullet and purchased a new solenoid from them and it  now works. Go figure :blink:.

If you have to buy, ORS LTD are considerable cheaper than Moss at £120 +vat.

Rich

 

Link to post
Share on other sites

Hi Rich,

Thanks for the update. To be honest I am not very hopeful of the solenoid working but won't find out for a while unless I jack up the back of the car and try it.

ORS did the overdrive on my TR6 + some machining on the 2nd gear. Reasonable price and good service.

Thanks Eddie 

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...

Important Information

Please familiarise yourself with our Terms and Conditions. By using this site, you agree to the following: Terms of Use.