Jump to content

Recommended Posts

Meant to say on my post 2 up from here, I can confirm that my Ammeter is Lucas while all other instruments are Smiths.

The 2 inch Oil pressure, temperature and petrol tank level instruments have no identification references at all. 

The Lucas Ammeter has the ref stamped on the rim of the back casing 36412B then 11 67, presumably the date of manufacture November 1967.

Dave McD  

Link to post
Share on other sites

Hi Dave,

I had to carefully open the tabs on the back a bit ( not too much, they will braek easily), and removed all sealant where possible with a sharp thin knife. The sealant was hard, brittle in my case. I did not use any special tools. Once rotated a bit they came off easily. Cleaned everything, also the glass with a common glass cleaner, both sides. Be careful with cleaning the black dial plate or the needle, I just carefully wiped it with a dry piece of cloth, that was all  that was needed.

After sanding and painting the beezels, I installed them, think you can order thin O- rings for this, but I still used silicone sealant because I was not convinced it would avoid water ingress. The end result was very good.

A nice, rewarding job overall.

Cheers,
Waldi

Link to post
Share on other sites

Wow, good progress Dave!

A couple of points easily forgotten for your consideration:

Is there a hole for an aerial (forgot to close it on mine).

Holes for mirrors, tonneau, hood in correct location and number!

Door sill chrome strip holes present and in one straight line (mine were not).

Others may have additional points to check.

Cheers,
Waldi

 

Link to post
Share on other sites
19 hours ago, Dave McDonald said:

 

Thanks for the comments about dash screws/cups and glove box hinges and lock being black as well as the instrument bezels. I'll have to look at these small detail items, which are currently packed away with everything else, when I came to reassemble the car. I can't remember what the cups and screws were but the car was restored previously in 1993/94 for the previous owner so may not be original anyway. What I am pretty sure of is that the glove box lock is chrome and also fitted with the finger pull, which I think is a TR4 fitting.

Dave McD 

Hi Dave my hinges and lock are chrome with no pull on the lock

i managed to get rubber rings for 2" gauges on ebay. Ask if you want details.

That is a strange location for your seat belt rear mountings.

Roy

Link to post
Share on other sites
8 hours ago, Waldi said:

Wow, good progress Dave!

A couple of points easily forgotten for your consideration:

Is there a hole for an aerial (forgot to close it on mine).

Holes for mirrors, tonneau, hood in correct location and number!

Door sill chrome strip holes present and in one straight line (mine were not).

Others may have additional points to check.

Cheers,
Waldi

 

Waldi,

Not particularly good progress really. I collected the shell from having new floors and sills, etc at the end of June. It's taken me until now to finalise lots of other small details.

Among those details has been making sure that I have every single hole drilled and captive nut welded in place and every single hole that I didn't want has been welded up. No aerial hole and I believe all hood fixings, trim fixing holes, etc, etc are now complete. I won't be fitting the bottom sill trim. I know it should be there but it just seems like an ideal place for water entry. I've seen a TR5 without it and didn't feel it looked odd. My choice so that's it. So thanks for the pointers but I think I've got it all covered.

Dave 

 

Link to post
Share on other sites

 Its all about the definition of slow:) I did a very quick restoration on my car, only 5 years;)
Most important is to keep joy in it.

Cheers,

Waldi

Link to post
Share on other sites
  • 2 weeks later...

My wife’s 1969 cp 25198 had chrome screws, hinges, lock  when I collected it from the seller many years ago. But strangely black on the windscreen dash bolts? Tr5 I have is chrome on the bolts yet only a year between them and chrome for the rest. Strange. As Stuart mentioned maybe they had run out of chrome for the 6.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...

Important Information

Please familiarise yourself with our Terms and Conditions. By using this site, you agree to the following: Terms of Use.