Jump to content
JJohn

PI PROBLEMS

Recommended Posts

After the complete rebuild of my TR6 which was badly damaged when it lost a wheel at Blyton Park last May we are having a nightmare with the fuel system. The engine starts and runs smoothly until the throttle is opened when it goes to full rich and completely drowns the plugs.  The metering unit was rebuilt with all new seals and the car ran perfectly at the Harewood Practice Day in March.  The problems described have occurred since then.  A good friend loaned me a metering unit which had not run since an overhaul by Prestige but that changed nothing.  There is a huge volume of fuel pouring through the PRV and it even leaks out of the cover of the diaphragm housing.

I will be grateful for any advice.

Jim

Share this post


Link to post
Share on other sites

Check damage to fuel return pipe from metering unit to tank.

 

                              Harvey S. Maitland

Share this post


Link to post
Share on other sites

Hi Jim

what do you mean by “There is a huge volume of fuel pouring through the PRV and it even leaks out of the cover of the diaphragm housing”

Steve

Share this post


Link to post
Share on other sites
21 hours ago, JJohn said:

After the complete rebuild of my TR6 which was badly damaged when it lost a wheel at Blyton Park last May we are having a nightmare with the fuel system. The engine starts and runs smoothly until the throttle is opened when it goes to full rich and completely drowns the plugs.  The metering unit was rebuilt with all new seals and the car ran perfectly at the Harewood Practice Day in March.  The problems described have occurred since then.  A good friend loaned me a metering unit which had not run since an overhaul by Prestige but that changed nothing.  There is a huge volume of fuel pouring through the PRV and it even leaks out of the cover of the diaphragm housing.

I will be grateful for any advice.

Jim

I assume that you have one of these diaphragm PRV's. If you still have the original Lucas one I would have that refurbed and use that? Note: there is a very tight clearance tolerance on the valve, on the Lucas ones. My original one lasted 45 years and I bought a new Lucas type from KMI, no problems so far! I am not convinced about the diaphragm type yet as for me the key issue is what rubber compound has been used for the diaphragm .The suppliers will not tell me or do not know? I have had too much trouble with the injector and non return O ring seals over the last 20 years? So I need some convincing! When you say your wheel fell off, was it one of the rear stub axles breaking?

Bruce

Share this post


Link to post
Share on other sites

Thanks for your replies.  We may have found the problem.  The engine fires up cleanly but when the throttle is opened, the MU goes to full rich.  The link to which the cold start cable is connected is then at the full rich setting, even when the dash control for cold start is closed manually.  However, when the engine is switched off, the cold start link slowly moves to the off position.  There appears to be so much fuel pressure that the cold start mechanism is forced fully "on" and the cold start is moving to "off" and the pressure subsides.  I have borrowed a pressure and will check it tomorrow.  May be the PRV is faulty or needs adjusting?

Jim

Share this post


Link to post
Share on other sites

Apologies for typo errors!  I should have typed ".....the cold start mechanism is moving to "off" as the pressure subsides"  and "I have borrowed a pressure gauge....."

Jim

Share this post


Link to post
Share on other sites

I'd check the return line from the MU to the tank and make sure there something like a 5 thou gap on the cold start  enrichment cam.

Share this post


Link to post
Share on other sites

Thanks for responding Mike.  Fuel is pouring down the return to the tank.  The pressure, measured at the PRV is 100 psi.  The MU has been set up by someone with 40 years of experience who has never before witnessed this problem.  He believes we need an additional datum track return spring. Some MU's were, apparently, equipped with 2.  See attached photo.

If any member has one of these which they are prepared to let me have, please let me know, urgently.  I am due to compete at Harewood next Sat & Sun - 11/12 May - and some testing is needed before that.  Thanks!

20190505_132753.jpg

Share this post


Link to post
Share on other sites

If you are looking at the return to tank fuel flow from the PRV valve with the engine not running or at idle there will be nearly all the pump flow, its a positive displacement pump so what is not used by the MU will be sent back to the tank, that's the job of the PRV.

If you are saying the flow is from the little pipe at the front of the metering unit, then there are 2 O ring seals on the rotor inside the MU unit, that are letting fuel back to return. Normally there will just be a dribble from the pipe. There is also a large diaphragm on the plunger on the left of you above photo.

My metering unit only has one spring and all the PI books I have seen there is only one spring. I think you will find this spring is only used to return the rich/choke control.

John

Share this post


Link to post
Share on other sites

Thanks John

There is flow from the small pipe and also down the return pipe to the PRV.  However, and I may not have made it clear in my earlier posting, the pressure in the MU is forcing the mixture/choke control to full rich.  Hence the search for a second spring.  All the seals in the MU were renewed (due to ethanol damage) before the car was first run at a test day in March, where it ran perfectly.  It was on the next outing that the trouble began with fuel leakage from the plastic cover on the chamber shown on the earlier photo and very rich running.

Jim

Share this post


Link to post
Share on other sites

The MU before starting,  the link in your photo above must be in the fully lowered position, this is held down by the 2 springs above the diaphragm at the top under the black plastic top hat, this is actually the rich running position.

I think you need to do a vacuum test on the top diaphragm, just suck on the pipe from the manifold and seal the end of the pipe with your tongue, the vacuum should be held, and the link should be held up, if it doesn't rise up there will be a problem with the diaphragm.  Have you checked the engine vacuum at idle?

The vacuum from the engine as soon as you start the engine will raise the link, putting it into a leaner position further up the ramp.

There shouldn't be a great amount of fuel coming from the return port at the MU it should be like a little dribble, if its more it must be the 2 O rings not sealing I think there is a an amount quoted by I don't see it just yet, I would have to look it up, but shouldn't  be anything like a flow, more like a few dribbles.

John

Share this post


Link to post
Share on other sites

Are you sure the fuelling diaphragm is a tight fit on the shaft? I replaced one, using a new item from one of the major suppliers, and it lasted less than an hour on Australian high octane unleaded before the MU went to super rich and fuel started pouring out of the MU vent.

When I disassembled the MU the new diaphragm had expanded on the MU shaft and no longer sealed. Other than that the diaphragm looked to be in good shape.

Share this post


Link to post
Share on other sites

Reply for Bruce:

Yes, it was failure of a rear stub axle, between the inner & outer bearings which caused the wheel to depart.  This happened on a 70mph bend and caused the car to barrel roll and land on the roof.  It then slid for about 50 yards before coming to a standstill.  The only undamaged panel was the boot lid. Stronger rear hubs now fitted!!

 

Jim

Share this post


Link to post
Share on other sites

Hi Everyone!

Thank you to those who replied to my plea for help.  The problem appears to have been identified thanks to advice from Neil who suggested that there may be an obstruction in the return line from the MU to the tank.  He was spot on.  We  rigged a temporary 1/4" external line and the engine now runs  without wild enrichment.  We have decided to run a new permanent line, using 1/4" copper pipe and expect to be ready for Harewood this weekend.  Thanks again to you all and especially to Neil.

What a great tool this Forum is!

Jim

 

Share this post


Link to post
Share on other sites
22 hours ago, JJohn said:

Reply for Bruce:

Yes, it was failure of a rear stub axle, between the inner & outer bearings which caused the wheel to depart.  This happened on a 70mph bend and caused the car to barrel roll and land on the roof.  It then slid for about 50 yards before coming to a standstill.  The only undamaged panel was the boot lid. Stronger rear hubs now fitted!!

 

Jim

Hi Jim,

I am glad you got away safely from that experience. I was in a friends TR4 when that happen, We were turning into my drive and there was a bang and his nearside wheel came rolling past us?

Bruce.

Share this post


Link to post
Share on other sites

I managed a road test run yesterday between the downpours.  Pleased to report that the TR6 is back on full song!  Harewood this weekend here we come.  When we removed the 3/16" return line we discovered the blockage. It was in the hose connection to the tank.  That piece of hose was almost totally blocked by what appeared to be fragments of its lining.  Modern fuel I expect.  The fuel has, in my 5 year ownership, always had additives which supposedly prevent this kind of thing.  Onward and hopefully upwards!

Thanks again to the offers of advice.

Jim

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...

Important Information

Please familiarise yourself with our Terms and Conditions. By using this site, you agree to the following: Terms of Use.