Jump to content
Sign in to follow this  
Yellowperil

Engine rattle

Recommended Posts

I started engine for first time in a few months today and had a misfire and intermittent top end rattle.

Took cover off and found that a rocker had jumped off the top of the pushrod. Never seen anything like that before.

Any ideas of cause?

Valve clearances all in spec.

Share this post


Link to post
Share on other sites

Jeremy

I reckon a valve momentarily stuck open, the push rod came out of the socket on the rocker arm and fell down as the cam rotated, then came wobbling upwards on the next stroke , by which time the valve had loosened and valve and rocker returned to normal position to be met by push rod coming up and missing the socket. For some reason, often when it does this, it doesn't always re- engage with the socket on the rocker arm.

You need to check the push rod hasn't got bent in the process - I had this very issue on my TR4 after a long layoff.

If 4 pot push rods are the same as 6 cylinder ones, I have some spares

cheers

Rich

Share this post


Link to post
Share on other sites

Well done - I suggest you use it more frequently and give it an good Italian tune up to prevent further occurrences!!

See you at the Alma in 10 days time^_^

cheers

Rich

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...

Important Information

Please familiarise yourself with our Terms and Conditions. By using this site, you agree to the following: Terms of Use.