Jump to content
Sign in to follow this  
johnw

Electronic Ignition.

Recommended Posts

2 hours ago, stuart said:

Yet another reason why I stick to points! ;):lol: #oldschool

Stuart.

Yes Stuart, lesson learned (even at my age)

As a matter of interest do you use a dwell meter to check the points gap?

Also the timing is 11deg BTDC static. With a 7deg cam inside am I correct in assuming

that max advance using a strobe would be 18deg.

Many thanks

John

 

 

 

 

Share this post


Link to post
Share on other sites

You can often get as much as 28deg depending on engine spec.

Stuart.

Share this post


Link to post
Share on other sites
15 hours ago, oldtuckunder said:

11 deg static is crank deg, 7 deg Dissy is half crank deg, so your max advance measured at crank should be 11 + (7x2) = 25

Alan

 

3 hours ago, stuart said:

You can often get as much as 28deg depending on engine spec.

Stuart.

Thanks both for the info.

John

 

 

 

Share this post


Link to post
Share on other sites

I wonder if there is another issue dragging it down? I have the pertronix unit and I’ve just been out to start the car for a spin and thought I’d stick a voltmeter on the battery. The cars not been out for a couple of weeks but it was reading 11.6 volts. Cranking over a bit slowly but it still fired up after a few turns. This is still the original  Mr Lucas starter motor.

Share this post


Link to post
Share on other sites
On 9/24/2018 at 1:26 PM, DaveN said:

I wonder if there is another issue dragging it down? I have the pertronix unit and I’ve just been out to start the car for a spin and thought I’d stick a voltmeter on the battery. The cars not been out for a couple of weeks but it was reading 11.6 volts. Cranking over a bit slowly but it still fired up after a few turns. This is still the original  Mr Lucas starter motor.

I think you may be right DaveN and I will have a better look over the winter. I'm pretty sure it's not an earth problem.

Certainly your voltage is much better than mine but it sounds as though your starter is cranking slower than mine.

First stop will be the starter which is the re conditioned original, all be it 30 years ago but not many miles.

At the moment it runs fine on points so will wait for the weather to turn. Went out in it today and ran like a train.

Many thanks for your input

John

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...

Important Information

Please familiarise yourself with our Terms and Conditions. By using this site, you agree to the following: Terms of Use.