Jump to content

Tacho problem

Recommended Posts



My tacho stopped working some time ago and I was advised to change the cable as these can give problems. So I changed the cable but still no reading. I removed the tacho and tried it with a spare cable direct into the distributor and hey presto it worked, so then I put it loosely back into the dash and it was still working. Once it was all screwed back together it had stopped working. I have repeated this palaver 3 times now with the same result.

It has occured to me that the inner cable might be too short as there is not a lot of the "squared" end of the inner cable protruding from the outer. Has anyone else had the same problem or can offer some advice?


Thanks in advance,



Link to post
Share on other sites

Some of the new inners have too long a piece from the plastic "Top hat" so when screwed right in they stop the tach working, if its working when you unscrew it a bit then thats the problem.


Edited by stuart
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...

Important Information

Please familiarise yourself with our Terms and Conditions. By using this site, you agree to the following: Terms of Use.