Jump to content
Sign in to follow this  
delboy

Brakes

Recommended Posts

Hi I am having trouble with my brakes pulling to the left on my TR6 .I have removed pads on right hand caliper and made sure piston are free and return moving freely.Checked rear r/hand brake all seams well clean and moving smoothly. Is there anything else to look for that will cause car to pull to left?

 

Thanks Delboy

Edited by delboy

Share this post


Link to post
Share on other sites

Is it a constant sharp pull or does it even out with more pressure?

Have you given the r/h caliper a quick bleed to eliminate a poss air bubble?

Wont hurt to give them all a bleed while you are at it.

Also check that the l/h caliper hasnt got a sticky piston that will cause it to grab quicker than the r/h side!

Share this post


Link to post
Share on other sites

hi delboy

] had this problem for a while once ,turned out it was the braided hose to the caliper had

gone internally .let pressure on and not let it off passed at least 2 mots passed with it !

Also a lot off smoke (burn in grease )into the passenger footwell once on to the future wife

she was not impressed !

Share this post


Link to post
Share on other sites

Hi

Thanks Pilke & JMO for your reply found problem not the brakes at all, they are fine.But found a cracked wishbone chassis bracket on front N/Side allowing movment.Just driven back from Prescot[oops]Off to find a good welder in Coventry Area

Thanks again.

Delboy

Edited by delboy

Share this post


Link to post
Share on other sites

That will do it! ;)

I had the same thing a couple of years ago! :(

Pretty damned frightening,but luckily it was the n/s rear one that totally collapsed stopping the wheel from folding under the car! :o

If it is just a stress crack due to the strengtheners either not there or not attached properly!"as in my case", you may be able to get it welded back on and then really BEEF up the strengtheners.

If however you are unlucky and its due to rust,then major surgery will have to be done! :(

All the best!

ps,I think I had just done Prescott and the hill in 08 when mine gave out! :blink:

Share this post


Link to post
Share on other sites

Hi

Thanks to Pilke & JMO for your reply on brakes pulling.Unfortunatly have found out why .Both front brakes fine but found a badly cracked wishbone chassis bracket on near side.So off to find a good welder in Coventry.

thanks for advice

Delboy

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...

Important Information

Please familiarise yourself with our Terms and Conditions. By using this site, you agree to the following: Terms of Use.