Jump to content

Search the Community

Showing results for tags 'oil pressure'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • TR Register Information
    • JOIN THE TR REGISTER
    • Find your local TR Register group
    • TR Register News
    • Events
    • TR Register Insurance
  • Parts and Cars
    • Classifieds
    • For Sale, Swap or Wanted, maximum value £250
  • TR Register's TR Chat
    • TRIUMPH AND MG WEEKEND CANCELLED
    • TRs Out and About
    • General TR Technical
    • TR2/3/3A/3B Forum
    • TR4/4A Forum
    • TR5/250 Forum
    • TR6 Forum
    • TR7/8 Forum
    • Italia, Swallow Doretti, Peerless & Warwick
    • TR Motorsport
    • TRs Re-United
    • Social Scene
  • Help Topics
    • Forum Help / Rules
  • Useful Links
    • Contact the office
    • Facebook
    • Twitter
    • Members' websites

Calendars

  • Forthcoming Events
  • Community Calendar

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Location


Cars Owned:

Found 1 result

  1. Hello Everyone, We are a bit stuck and would welcome any help or suggestions please. Having finally got round to changing the diff mounts on my 1972 TR6 I now have another worrying issue as no oil pressure. Probably my fault due to lack of use as she has been sat waiting to come out into the sunshine for over 2 years, but oil pressure was fine when last used. That said she fires up and ironically seems to be running fine, except now no oil pressure. Obvioulsy I have only run her for a few seconds at a time whilst trying to sort her out. So far we have taken off the pre
×
×
  • Create New...

Important Information

Please familiarise yourself with our Terms and Conditions. By using this site, you agree to the following: Terms of Use.