Jump to content

jocklow

Registered User
  • Content Count

    30
  • Joined

  • Last visited

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. Not the problem. But I do see what you mean. That would require the little mini piston and seal at the inlet end of the cylinder to slip backwards freely, because when the whole system has air in it instead of fluid, there's not going to be much suck. What is the purpose of the nylon cage that sits on the end of the mini pistion and holds the seal on the end of the piston. I can't find a drawing of the cylinder , just sketches of the exterior.
  2. I have been rebuilding my discs (TR3A) with new pistons and seals. But now that I need to bleed the system I cannot get the master cylinder to pump fluid ( with a brake bleeding non return valve on the caliper bleed screw. I've even tried disconnecting the outlet at the master cylinder and putting my finger over it. When I compress the piston it pushes air out of the outlet past my finger but it doesn't suck in fluid on the return stroke. I've dismantled the cylinder and the spring pushing the the piston and seal that closes the line to the reservoir is so strong I can't compress it by hand.
  3. First, thanks to you for your comments and tips. The engine cannot be turned by hand on the fan. The oil pressure hot at, say, 2200rpm is 60-70psi. So no problem.The starter is a hi-torque modern starter. You can unjam the engine by bumping the car, even by one person on a flat road. So not truly seized, just sort of nipped. I think I would have melted any white metal bearings if they were the problem. So that leaves the piston rings. Are you really saying that I needed to file or grind the ends of new piston rings bought with the new pistons. I never worked in a car factory but i'm prett
  4. HI, I rebuilt my TR3a engine with new liners (larger ), new pistons and rings, bearings etc. When cold it turns over and starts beautifully. However if you go out for a 30 min run (water temp 85c-90c ish, the weather being quite hot) and then stop and turn off the engine, leave it 10 mins you can't restart because it has seized. Leave it longer and it'll start again. I admit I have probably only gone two or three hundred miles since this rebuild, but it's showing no sign of improving. Do I just need to do more miles, or do I need to take the head off and roughen up the bores ?
  5. Thanks for all observations. Re access, I have the rubber plug in the gearbox housing but no filler or dipstick under it. So it seems filling through the side plug is correct, although inconvenient to put it mildly. I will drain and refill as advised and see how that goes.
  6. The overdrive is taking about 10 to 15 seconds to engage. ( I feel it used to be more or less immediate.) Having checked my various manuals I believe the overdive oil level is determined by the gearbox level, so I topped up the gearbox oil. Using 20/50 engine oil. I feel this hasn't made any difference. My manuals all showed that you used regular engine oil in the gearbox. (But the manuals were both written 40-60 years ago.) It doesn't drop out of engagement even at low revs. Is the oil too thin ( maybe for my worn pump) or is it more likely to be something sticking in the actuator m
  7. Master cylinder is Girling, from Moss. Bought late last summer. But I haven't heard of any problems with hydraulic fluid. Is there some type that I should avoid because it will eat the seals ? Also, I've read up in the workshop manual about replacing the seals in the master cylinder. The implication is that once you remove the push rod, boot and a circlip the piston is pushed out by the return spring. Because otherwise I don't see how you get it out without compressed air in the other end.Is that right? Thanks for any advice.
  8. Today's problem. If I depress the brake pedal slowly I can press all the way to the floor - no brakes. But if I press down quickly the pedal hardens and I am actuating the brakes. And if I do this with the top off the reservoir oil is squirted up in to the reservoir and squirts up out of the open top. This must be oil being pushed back through the feed to the master cylinder and into the reservoir. I guess this is the one-way valve in the mastercylinder not closing. But it's a new master cylinder !! Been used for say 100-200 miles. Anybody else had this problem ?
  9. I am fitting a new clutch slave cylinder and hose ( to solve my slow release clutch problem of a few posts ago - I think it was the hose, thanks). But I can't get any fluid pumped through the system. I think when I was disconnecting the old cylinder I tried working the clutch when the rod that bears on the release arm was disconnected - I was still trying to find out which bit of the system was sticking. That presumably pushed the piston in the master cylinder fully in. Now it is all connected with the new parts I can't get it to pump any oil, I presume because the piston on the master cylind
  10. Ok, thanks for the tips.I'm hoping for the new hose solution and will check the cylinders at the same time. The outside of the hose is awful, so I'm hoping that's the answer. Didn't occur to me that the hose could collapse. I feared it would be like discs sticking on when it seems to be the brake cylinders. I don't like the look of the dodgy release bearing shaft version. I've had the gearbox out of my car three times and I don't look forward to the fouirth. Thanks
  11. Has anyone experienced the clutch , and clutch pedal coming back up slowly after you take your foot off it after changing gear ? Obviously something is sticking. I tried disconnecting the slave cylinder from the arm that pushes on the release bearing and then working the clutch by hand.But you can't get enough leverage lying under the car to depress the clutch. So I don't really know where the element that isn't free moving is. The clutch arm, the slave cylinder or the master cylinder. The pedal flops about so it isn't that. I suppose I will start with the slave cylinder. But I wonder if an
  12. Try Autoservice & Spares Ltd in Exeter, 01392 272429. They flash ground the head, fitted new valve seats and valves, for about £350 inc vat, in 2013. They were recommended to me by a very fussy owner (and highly skilled toolmaker) of vintage Rileys. I thought the fact that they had a Ferrari crankshaft in for a regrind when I went in was a good sign as well.
  13. I had poor starting as described and had to use Easystart. Eventually discovered poor compression . Valve seats burned and needing replacing/reseating. ( I also replaced liners, pistons, rings etc etc but I'm fairly sure the real problem was the valves. You will put in new harder valve seats and not need to worry about burning them out in future.)
  14. I have three photos from my brief ownership. They are from the winter of 1967, so it is perhaps unsurprising that they are black and white. I only have the prints so the quality is not brilliant.
  15. Further to MWK 950 -engine nos. The owner has sent me a copy of the logbook, which I'm pleased to see shows me as one of the owners. However of interest to others may be that the car was initially registered with engine no V175804, a vanguard engine, which was changed by Standard Motor Co to X571 in Jan 1954, and then later, in 1956 to TS31E (which apparently has a double barrelled thermostat). It was originally registered Blue and changed to British RAcing Green in 1956 before the last engine change, and presumably therefore while still owned by Standard Motor Co. By the late '60's it had r
×
×
  • Create New...

Important Information

Please familiarise yourself with our Terms and Conditions. By using this site, you agree to the following: Terms of Use.