Jump to content

keith ardley

Registered User
  • Content Count

    7
  • Joined

  • Last visited

Community Reputation

0 Neutral

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. https://photos.app.goo.gl/iLinDGm6UPnbPNUA9 Triumph 2.5 engine fitted in my Bristol 401 having all the problems with the gear box as posted above ( didn't know how to post pic in last post ) https://photos.app.goo.gl/N2MbYdWo5CrR3Rjp8
  2. that's something I must look at as I should have mentioned the engine I fitted is in a Bristol 401 and had to make up the mounting plates for the slave cylinder y so will check this thanks
  3. Hi just fitted new clutch and now unable to engage reverse All forward gears ok have also fitted ne spring to gear stick (ante rattle? ) lifts over to reverse but sounds like its riding on top of the gear and not engaging revers gear seems to be going to fast to slip into gear will go in when engine if not running any ideas what to do ??? could it be the clutch is not disengaging correctly ?
  4. Thanks for info Now sorted Keith
  5. Thanks Rodger for responding that's the answer then, as its a new spring and plunger did think this may be the case but thinking of getting advice first thanks Keith
  6. Hi new to Triumphs in need of advice pleas How do you assemble the spring and plunger in the base of the gear stick into the housing seems a impossible problem help pleas https://photos.app.goo.gl/MkLNrpUone3Cp6cK7
×
×
  • Create New...

Important Information

Please familiarise yourself with our Terms and Conditions. By using this site, you agree to the following: Terms of Use.